XML формат

Чем открыть, описание – 1 формат файла

image Документ XML XML File Тип файла: Файлы данных Тип данных: XML-документ Mime-type: text/xml Разработчик: Неизвестно

Заголовок и ключевые строки

HEX: 3C 3F 78 6D 6C 20 76 65 72 73 69 6F 6E 3DASCII: <?xml version=</div>

Подробное описание

XML — расширяемый язык разметки (англ. Extensible Markup Language). Файл XML — документ, в котором использованы теги для определения объектов и их атрибутов. Форматирование данных напоминает язык разметки HTML-документов. Но в отличие от HTML, в XML используются теги, которые задаются пользователями.

Структура XML-документа представляет собой дерево элементов. Некоторые элементы имеют содержимое и атрибуты. Например, value Здесь , — открывающий и закрывающий теги элемента, attr — атрибут, attrval — значение атрибута, value — содержимое.

XML-файлы и файлы других расширений, основанные на языке XML, получили очень широкое распространение. В XML-файлах хранятся самые различные данные — от настроек приложений до баз данных. Файлы на основе XML используются для обмена информацией в Интернете и между программами (для этого данный язык разметки и был изначально задуман). Т.к. файлы формата XML содержат текстовые данные, их можно легко отредактировать в любом текстовом редакторе.

Как, чем открыть файл .xml?

Инструкция — как выбрать программу из списка, скачать и использовать ее для открытия файла

Для более точного определения формата и программ для открытия файла используйте функцию определения формата файла по расширению и по данным (заголовку) файла.

Сегодня я расскажу вам как, и главное, в чём создать файл XML. XML файл — это расширяемый язык разметки, Что это значит, простым языком, читайте далее.

image

Файлы xml используются во многих областях программирования. Данный формат позволяет создавать практически любые теги и декларации.

Файлы XML также используются для удобства обработки, хранения и передачи данных. Так, например, если у Интернет-сайта карта сохранена в XML, то на неё будет легче добавлять любую требующуюся информацию.

К примеру, это могут быть новые страницы и прочее. В этом материале вы узнаете, как происходит создание файлов в подобном формате.

Как создать файл XML

Если вам потребовалось создать файл XML, тогда можно воспользоваться одним из вариантов:

  • Visual Studio.
  • MS Excel.
  • Блокнот и другие программы.

 У каждого из вышеперечисленных способов имеется свои нюансы, с которыми стоит познакомиться поближе.

Создание файла XML в Visual Studio

Visual Studio – более улучшенная, многофункциональная версия «Блокнота».

Для её использования, сначала нужно скачать и установить программу, а затем:

  • В левом верхнем углу программы, нужно нажать на «Файл» и выбрать пункт «Создать».
  • Далее, в новом системном окне выбираете соответствующий тип файла и в правом нижнем углу нажимаете «Открыть».
  • Затем прописываете всю необходимую информацию.
  • Для сохранения данных выбираете «Сохранить всё».

Во время сохранения проследите, чтобы расширение было XML.

Как создать xml файл в Excel

Ещё одним способом, по созданию файла XML, является использование MS Excel:

  • Сначала запускаете MS Excel и посредством использования одного из языков программирования вводите все требуемые команды в таблицу.
  • Далее, в верхнем левом углу нажимаете на кнопку Microsoft Office и выбираете раздел «Сохранить как».
  • В графе «Тип файла» из списка выбираете « XML-данные» и кликаете по «Сохранить».

Как создать xml файл в блокноте

Вариант создания файла формата XML через Блокнот, более сложный, по сравнению с ранее приведёнными способами.

В этом случае придётся самостоятельно прописывать все необходимые команды и теги.

Итак, чтобы создать XML-файл с помощью утилиты «Блокнот» потребуется:

  • Сначала создаётся новый текстовый документ. То есть на рабочем столе или в любой папке, по пустому месту нужно щелкнуть правой клавишей мыши и выбрать пункт «Создать», а затем кликаете по «Текстовый документ».
  • Далее задаётся кодировка файла с указанием его формата. Для этого используется следующая команда без кавычек: «<?xml version=”1.0” encoding=”utf-8” ». </li>

Затем создаётся первый каталог. Для закрытия каталога применяется символ «/». Таким образом, на второй строчке документа прописываете тег .

  • Далее прописывается контент, для которого можно использовать тег с присваиванием ему имени. Теперь тег будет выглядеть так: < Employee name=”имя”>. Здесь же можно добавить ещё дополнительные данные, которые должны вводиться с новой строки. Например, возраст 20 True и другие данные.
  • Для закрытия тэга , используется символ «/». Таким образом, тег примет следующий вид — . 
  • Далее закрываете каталог при помощи символа «/». То есть, на второй строчке документа прописываете тег

Я думаю, что Вы уже представляете себе, зачем нужен HTML (да, HTML). Он нужен для представления данных в браузере. То есть имеется HTML-код и соответствующий этому HTML-коду определённый вид. Однако, современные тенденции требуют не просто отображения данных, но ещё и их грамотной внутренней структуры.

Вот именно для создания структуры и существует язык XML. Простой пример:

Зелёное яблоко

Для нас людей сразу всё становится понятно. В голове возникает сразу образ «зелёного яблока«, однако, как объяснить компьютеру, что это яблоко, а не апельсин, человек или наша галактика? Здесь вновь приходит на помощь XML, где мы можем создавать любые теги, давая чётко понять, где яблоко, где апельсин, где человек, а где наша галактика. Надеюсь, понятно объяснил.

Теперь о самом главном. Главная особенность XML — это его универсальность. То есть XML понимает любой современный язык. А так как XML — это текстовый файл, то с ним можно работать и в обычном блокноте. Теперь конкретно к практике, где используется XML:

  • Файл-настроек. Настройки в XML-файле очень легко считывать и записывать. По этой причине на Вашем компьютере находятся сотни XML-файлов.
  • Мост для обмена данными между программами, написанными на разных языках. Очень важная особенность, следующая из универсальности языка, и это регулярно используется в сложных системах.
  • Хранение данных. Фактически, это некий аналог базы данных, но не требующий СУБД (например, MySQL). А благодаря языку запросов XPath становится возможным легко общаться с этой «базой данных«.

И, наконец, из своей практики могу привести самый простой пример. У меня на сайте есть карта сайта в формате XML. Там находятся ссылки на все страницы сайта. Это вещь весьма удобная и важная для хорошей индексации сайта, однако, каждый раз вручную добавлять туда новую страницу неудобно. Поэтому благодаря знаниям по работе с XML, я это дело легко автоматизировал. Так что XML — полезный язык, который надо знать любому программисту хотя бы в общих чертах.

  • Создано 31.05.2011 13:11:16
  • Михаил Русаков

Чтение и запись XML в языке 1С 8.3, 8.2 (в примерах)

Всё для программиста >> Справочник языка 1С

Вступайте в мою группу помощник программиста. В ней мы обсуждаем программирование в 1С.

<<< <span> XML ZIP WORD DBF HTTP FTP ТекстовыйДокумент ТабличныйДокумент

Скачать эти примеры в виде тестовой базы (как загрузить, как исследовать) Скачать test.xml, который используется в примерах ниже.

/// Как прочитать файл в формате XML через DOM /// в 1с 8.3, 8.2   &НаСервере Процедура ПрочитатьФайлXMLЧерезDOM(ПутьКФайлу)       // Разбор документа через DOM (document object model) // https://ru.wikipedia.org/wiki/Document_Object_Model       // Разбираем файл test.xml, ссылка на его скачивание выше.       Парсер = Новый ЧтениеXML;     Парсер.ОткрытьФайл(ПутьКФайлу);       Построитель = Новый ПостроительDOM;       Документ = Построитель.Прочитать(Парсер);       Для Каждого Элемент  Из Документ.ЭлементДокумента.ДочерниеУзлы Цикл Если Элемент .ИмяУзла = "Страна" Тогда             Страна = Элемент ;               Название = Страна.Атрибуты.ПолучитьИменованныйЭлемент("Название"); Если Название <> Неопределено Тогда                 Сообщить("== " + Название.Значение + " =="); КонецЕсли;               Численность = Страна.Атрибуты.ПолучитьИменованныйЭлемент("Численность"); Если Численность <> Неопределено Тогда                 Сообщить("Численность: " + Численность.Значение); КонецЕсли;               Столица = Страна.Атрибуты.ПолучитьИменованныйЭлемент("Столица"); Если Столица <> Неопределено Тогда                 Сообщить("Столица: " + Столица.Значение); КонецЕсли;               Для Каждого Элемент1 Из Страна.ДочерниеУзлы Цикл Если Элемент1.ИмяУзла = "ТрадиционныеБлюда" Тогда                     ТрадиционныеБлюда = Элемент1;                       Сообщить("Традиционные блюда:");                       Для Каждого Элемент2 Из ТрадиционныеБлюда.ДочерниеУзлы Цикл Если Элемент2.ИмяУзла = "Блюдо" Тогда                             Блюдо = Элемент2;                               Название = Блюдо.Атрибуты.ПолучитьИменованныйЭлемент("Название"); Если Название <> Неопределено Тогда                                 Сообщить(" " + Название.Значение); КонецЕсли; КонецЕсли; КонецЦикла; ИначеЕсли Элемент1.ИмяУзла = "ОбщееОписание" Тогда                     Сообщить("Общее описание:");                     Сообщить(Элемент1.ТекстовоеСодержимое); КонецЕсли; КонецЦикла; КонецЕсли; КонецЦикла;       Парсер.Закрыть();   КонецПроцедуры   /// Как прочитать файл в формате XML последовательно /// (способ 1) в 1с 8.3, 8.2   &НаСервере Процедура ПрочитатьФайлXMLПоследовательноСпособ1(ПутьКФайлу)       // Этот способ подойдёт для очень больших файлов, // для которых модель DOM неприменима.       // Способ 1.       // Разбираем файл test.xml, ссылка на его скачивание выше.       Парсер = Новый ЧтениеXML;     Парсер.ОткрытьФайл(ПутьКФайлу);       Пока Парсер.Прочитать() Цикл Если              Парсер.ТипУзла = ТипУзлаXML.НачалоЭлемента И             Парсер.Имя = "Страна" Тогда             Название = Парсер.ЗначениеАтрибута("Название"); Если Название <> Неопределено Тогда                 Сообщить("== " + Название + " =="); КонецЕсли;               Численность = Парсер.ЗначениеАтрибута("Численность"); Если Численность <> Неопределено Тогда                 Сообщить("Численность: " + Численность); КонецЕсли;               Столица = Парсер.ЗначениеАтрибута("Столица"); Если Столица <> Неопределено Тогда                 Сообщить("Столица: " + Столица); КонецЕсли;               Пока Парсер.Прочитать() Цикл // <Страна> Если                      Парсер.ТипУзла = ТипУзлаXML.НачалоЭлемента И                     Парсер.Имя = "ТрадиционныеБлюда" Тогда                                         Сообщить("Традиционные блюда:");                       Пока Парсер.Прочитать() Цикл // <ТрадиционныеБлюда> Если                              Парсер.ТипУзла = ТипУзлаXML.НачалоЭлемента И                             Парсер.Имя = "Блюдо" Тогда                             Название = Парсер.ЗначениеАтрибута("Название"); Если Название <> Неопределено Тогда                                 Сообщить(" " + Название); КонецЕсли; ИначеЕсли                             Парсер.ТипУзла = ТипУзлаXML.КонецЭлемента И                             Парсер.Имя = "ТрадиционныеБлюда" Тогда Прервать; КонецЕсли; КонецЦикла; //  </ТрадиционныеБлюда>                   ИначеЕсли                     Парсер.ТипУзла = ТипУзлаXML.НачалоЭлемента И                     Парсер.Имя = "ОбщееОписание" Тогда                                     Парсер.Прочитать(); Если Парсер.ТипУзла = ТипУзлаXML.Текст Тогда                         Сообщить("Общее описание:");                         Сообщить(Парсер.Значение); КонецЕсли; ИначеЕсли                     Парсер.ТипУзла = ТипУзлаXML.КонецЭлемента И                     Парсер.Имя = "Страна" Тогда Прервать; КонецЕсли; КонецЦикла; // </Страна>           КонецЕсли; КонецЦикла;       Парсер.Закрыть();   КонецПроцедуры   /// Как прочитать файл в формате XML последовательно /// (способ 2) в 1с 8.3, 8.2   &НаСервере Процедура ПрочитатьФайлXMLПоследовательноСпособ2(ПутьКФайлу)       // Этот способ подойдёт для очень больших файлов, // для которых модель DOM неприменима.       // Способ 2.       // Разбираем файл test.xml, ссылка на его скачивание выше.       Парсер = Новый ЧтениеXML;     Парсер.ОткрытьФайл(ПутьКФайлу);       СтекИмен = Новый СписокЗначений;       Пока Парсер.Прочитать() Цикл Если Парсер.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда             СтекИмен.Добавить(Парсер.Имя);             ПолныйПуть = ПостроитьПуть(СтекИмен);               Если ПолныйПуть = "/Страны/Страна" Тогда                 Название = Парсер.ЗначениеАтрибута("Название"); Если Название <> Неопределено Тогда                     Сообщить("== " + Название + " =="); КонецЕсли;                   Численность = Парсер.ЗначениеАтрибута("Численность"); Если Численность <> Неопределено Тогда                     Сообщить("Численность: " + Численность); КонецЕсли;                   Столица = Парсер.ЗначениеАтрибута("Столица"); Если Столица <> Неопределено Тогда                     Сообщить("Столица: " + Столица); КонецЕсли; ИначеЕсли ПолныйПуть = "/Страны/Страна/ТрадиционныеБлюда" Тогда                 Сообщить("Традиционные блюда:"); ИначеЕсли ПолныйПуть = "/Страны/Страна/ТрадиционныеБлюда/Блюдо" Тогда                 Название = Парсер.ЗначениеАтрибута("Название"); Если Название <> Неопределено Тогда                     Сообщить(" " + Название); КонецЕсли; ИначеЕсли ПолныйПуть = "/Страны/Страна/ОбщееОписание" Тогда                 Парсер.Прочитать(); Если Парсер.ТипУзла = ТипУзлаXML.Текст Тогда                     Сообщить("Общее описание:");                     Сообщить(Парсер.Значение); КонецЕсли; КонецЕсли; ИначеЕсли Парсер.ТипУзла = ТипУзлаXML.КонецЭлемента Тогда             СтекИмен.Удалить(СтекИмен.Количество() - 1); КонецЕсли; КонецЦикла;       Парсер.Закрыть();   КонецПроцедуры   /// Как записать данные в файл формата XML в 1с 8.3, 8.2   &НаКлиенте Процедура ЗаписатьДанныеВФорматеXML(ПутьКФайлуДляЗаписи)       // Предположим, что у нас есть данные о странах, // которые нужно записать во внешний файл в формате XML.           Страны = СоздатьДанныеДляЗаписиВXML();           // И эти данные хранятся во списке значений Страны, // который нам вернула внутренняя процедура (определена // ниже).       ЗаписьXML = Новый ЗаписьXML;       ЗаписьXML.ОткрытьФайл(ПутьКФайлуДляЗаписи);       ЗаписьXML.ЗаписатьОбъявлениеXML();           ЗаписьXML.ЗаписатьНачалоЭлемента("Страны");       Для Каждого Страна Из Страны Цикл         ЗаписьXML.ЗаписатьНачалоЭлемента("Страна");         ЗаписьXML.ЗаписатьАтрибут("Название", Страна.Значение.Название);         ЗаписьXML.ЗаписатьАтрибут("Численность", Страна.Значение.Численность);         ЗаписьXML.ЗаписатьАтрибут("Столица", Страна.Значение.Столица);           ЗаписьXML.ЗаписатьНачалоЭлемента("ТрадиционныеБлюда"); Для Каждого Блюдо Из Страна.Значение.ТрадиционныеБлюда Цикл             ЗаписьXML.ЗаписатьНачалоЭлемента("Блюдо");             ЗаписьXML.ЗаписатьАтрибут("Название", Блюдо.Значение.Название);             ЗаписьXML.ЗаписатьКонецЭлемента(); // Блюдо КонецЦикла;         ЗаписьXML.ЗаписатьКонецЭлемента(); // ТрадиционныеБлюда           ЗаписьXML.ЗаписатьНачалоЭлемента("ОбщееОписание");         ЗаписьXML.ЗаписатьТекст(Страна.Значение.ОбщееОписание);         ЗаписьXML.ЗаписатьКонецЭлемента(); // ОбщееОписание           ЗаписьXML.ЗаписатьКонецЭлемента(); // Страна КонецЦикла;       ЗаписьXML.ЗаписатьКонецЭлемента(); // Страны       ЗаписьXML.Закрыть();   КонецПроцедуры   &НаКлиенте Функция СоздатьДанныеДляЗаписиВXML()       Страны = Новый СписокЗначений;       Россия = Новый Структура("Название, Численность, Столица, ТрадиционныеБлюда, ОбщееОписание");     Россия.Название = "Россия";     Россия.Численность = "144000000";     Россия.Столица = "Москва";     Россия.ТрадиционныеБлюда = Новый СписокЗначений;     Россия.ТрадиционныеБлюда.Добавить(Новый Структура("Название", "Щи"));     Россия.ТрадиционныеБлюда.Добавить(Новый Структура("Название", "Солянка"));     Россия.ТрадиционныеБлюда.Добавить(Новый Структура("Название", "Рассольник"));     Россия.ОбщееОписание = "Страна с очень" + Символы.ПС + "большой территорией";         Страны.Добавить(Россия);       Китай = Новый Структура("Название, Численность, Столица, ТрадиционныеБлюда, ОбщееОписание");     Китай.Название = "Китай";     Китай.Численность = "1357000000";     Китай.Столица = "Пекин";     Китай.ТрадиционныеБлюда = Новый СписокЗначений;     Китай.ТрадиционныеБлюда.Добавить(Новый Структура("Название", "Свинина в кисло-сладком соусе"));     Китай.ТрадиционныеБлюда.Добавить(Новый Структура("Название", "Курица гунбао"));     Китай.ТрадиционныеБлюда.Добавить(Новый Структура("Название", "Мапо тофу"));     Китай.ОбщееОписание = "Страна с очень" + Символы.ПС + "большим населением.";     Страны.Добавить(Китай);       Возврат Страны;   КонецФункции   &НаСервере Функция ПостроитьПуть(СтекИмен)     Путь = "";       Для Каждого Имя Из СтекИмен Цикл         Путь = Путь + "/" + Имя; КонецЦикла;       Возврат Путь; КонецФункции   /// Скачать и выполнить эти примеры на компьютере

Скачать эти примеры в виде тестовой базы (как загрузить, как исследовать) Скачать test.xml, который используется в примерах ниже.

Чтение и запись XML в языке 1С 8.3, 8.2 (в примерах)

<<< <span> XML ZIP WORD DBF HTTP FTP ТекстовыйДокумент ТабличныйДокумент

С уважением, (преподаватель школы 1С программистов и разработчик обновлятора).Всё для программиста >> Справочник языка 1С

Подписывайтесь и получайте новые статьи и обработки на почту (не чаще 1 раза в неделю). Вступайте в мою группу ВКонтакте, Одноклассниках, Facebook или Google+ — самые последние обработки, исправления ошибок в 1С, всё выкладываю там в первую очередь.

Как помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.

Нажмите одну из кнопок, чтобы поделиться:

XML – расширяемый язык разметки. Он предназначен для создания документов, которые находят применение в сети. Он отличается от более распространённого и известного HTML только тем, что предоставляет возможность задавать собственные теги и применять их в дальнейшем. Чтобы работать с такими документами, редактировать их и вносить изменения, достаточно иметь начальные знания в программировании, он лёгок и прост в применении. Но прежде чем использовать такой документ, а тем более править его, необходимо знать, чем открыть XML.

Содержание

Открываем файлы в офлайн-режиме

Этот тип файлов имеет широкое распространение, в связи с чем популярность вопроса становится вполне оправданной. Так как документ содержит текстовую информацию, то разумно предположить, что для его открытия могут быть применимы типы программ, поддерживающих текстовый формат.

Блокнот

Один из первых вариантов, который приходит в голову опытному пользователю. Связано это с тем, что в большинстве своём код HTML правится именно в этой программе, значит и XML поддержит такой вариант.image

Это действительно так. При привычном открытии файла, пользователю предоставляется выбор, чем открыть XML, так как выполнить задачу может несколько программ. Предоставив такую возможность блокноту, пользователь получит сплошное полотно символов, из которых состоит код. Если всмотреться в содержимое, то человек имеющий представление о структуре этого кода поймёт, что все верно, с единственной пометкой – блокнот не поддерживает форматирование и весь код представлен сплошным текстом.

Microsoft Word

Ещё один вариант чем открыть XML, в отличие от предыдущего способа, современные версии текстового процессора открывают файлы в удобочитаемом формате. То есть код располагается в виде таблицы удобной для восприятия. Благодаря лучшему обзору содержимого упрощается и процесс внесения правок в документ.image

WordPad также отлично подойдёт для просмотра содержимого XML-файла. Для выбора программы необходимо щёлкнуть по документу правой кнопкой мыши и выбрать команду «открыть с помощью», в появившемся списке выбираем нужный текстовый редактор и получаем требующийся результат.

Notepad++

Многие считают эту программу одной из самых удобных для просмотра и редактирования XML-файлов. В первую очередь — это обусловлено высокой скоростью работы, в отличие от Word, редактор открывает в считанные секунды даже самый большой документ, при этом также быстро перестраивает содержимое в таблицу.image

Кроме этого, программа имеет большое количество возможностей, которые не реализованы в других текстовых редакторах. В случае недостаточности имеющихся функций, открытий код редактора всегда можно дополнить новыми плагинами или модулями.

Microsoft Excel

Табличный редактор тоже способен открыть и показать содержимое нужного документа. Удобство этой программы в том, что она автоматически предоставляет содержимое в виде удобной для восприятия таблицы.image

К недостаткам использования можно отнести тот факт, что ввиду ограничения на количество строк очень большой XML-файл может не открыться. Прежде чем открыть XML-файл в Excel, необходимо выбрать в качестве способа XML-таблицу.

Специализированные редакторы

Если встает вопрос чем открыть XML чтобы отредактировать его и внести изменения, то лучше отдать предпочтение специальному софту. Есть несколько вариантов таких разработок:

  • ;
  • ;
  • .

Это далеко не все варианты, есть и другие программы, созданные непосредственно для работы с файлами этого формата. Важно понимать, что каждая из них имеет собственные возможности, которые отличаются от других аналогов. Поэтому выбирать софт нужно в каждом конкретном случае в соответствии с потребностями.

Чем открыть XML в онлайн

Бывают ситуации, когда открыть и просмотреть содержимое файла XML необходимо, а на компьютере нет ни одной подходящей программы. Несмотря на широкий выбор возможных вариантов иногда случается и такое.

В этом случае пользователь может обратиться к онлайн-сервисам. Чем открыть XML через интернет?

Браузер

Эту возможность поддерживают все современные браузеры. Но важно учитывать, что документ не содержит информации о том, как именно должны быть отображено содержимое, соответственно браузер откроет его «как есть».image

Для того чтобы открыть нужный файл, необходимо щёлкнуть по нему правой кнопкой мыши и выбрать соответствующий браузер в качестве программы, если обозреватель не отображается в списке сразу, то можно найти его через «обзор». Файл будет открыт в новой вкладке, в случае если документ повреждён, то браузер не сможет его открыть и придётся искать офлайн-вариант.

Xmlgrid.net

Самый популярный онлайн-сервис для работы с документами формата XML. Он позволяет открывать, просматривать и вносить изменения в документы.

Для работы с редактором достаточно перейти на его страницу в интернете. С помощью команды Open File загружаем нужный документ и выполняем все задуманные действия. imageИнтерфейс реализован на английском языке, но в общих чертах все интуитивно понятно.

CodeBeautify

Ещё один онлайн-инструмент пригодный для работы с файлами данного формата. Прежде чем начать деятельность требуется пройти на сайт сервиса и выбрать тип документа, с которым планируется работа.image

Помимо открытия и редактирования документа, сервис позволяет произвести конвертацию содержимого в разные форматы.

XSL Transformation

Онлайн-сервис предназначен в первую очередь для преобразования и валидации имеющегося кода. Кроме того, имеет немало полезных инструментов, которые пригодятся мастеру, регулярно сталкивающемуся с необходимостью взаимодействия с документами формата XML.image

Таким образом, при необходимости работы с расширяемым языком всегда можно найти подходящую программу или онлайн-сервис, независимо от возможностей ПК. Тем не менее большинство инструментов позволяют только просмотреть содержимое и преобразовать его в удобную для восприятия таблицу. Для профессиональной работы с XML стоит отдать предпочтение специализированным программам.

Оцените статью
Рейтинг автора
5
Материал подготовил
Илья Коршунов
Наш эксперт
Написано статей
134
А как считаете Вы?
Напишите в комментариях, что вы думаете – согласны
ли со статьей или есть что добавить?
Добавить комментарий